Author Topic: DigisSpark wont work in Bios Settings :-(  (Read 2856 times)

user0815

  • Newbie
  • *
  • Posts: 2
DigisSpark wont work in Bios Settings :-(
« on: May 31, 2018, 03:18:24 am »
Good afternoon, everyone,

I've been trying to set up my digispark for hours
to work under the Bios Settings.
 
Several bios settings are to be automated
when the Digispark is plugged in.

On the shell or with a booted operating system
the Spark works great and use the embedded key strokes.

Unfortunately in Bios :  no chance!

have already found some in the net
but unfortunately no solution!

Short message for a solution or workaround
would be great!
« Last Edit: May 31, 2018, 03:21:00 am by user0815 »

esc98

  • Newbie
  • *
  • Posts: 2
Re: DigisSpark wont work in Bios Settings :-(
« Reply #1 on: May 31, 2018, 04:30:17 am »
I tried to use my digistump for this as well, but couldn't set it properly. There is one person that was working on it but I couldn't set the USB config correctly:
Digispark as HID Keyboard on preboot doesnt work

I wrote about it in my thread: Digispark won't act as keyboard on PC boot
My final code for Arduino Mega is also linked there.

whocares1

  • Newbie
  • *
  • Posts: 4
Re: DigisSpark wont work in Bios Settings :-(
« Reply #2 on: June 01, 2018, 01:40:31 pm »
This hole boot keyboard thing has been a issue since 2013.

As you and many others we been searching ever since on how to fix the lazyness of the money hungry operators of digispark
digispark is not a company interested in long term support or quality of work.
They are more of a "hey we no longer make this digispark because we need the money to fund our new products that we will half ass and then hype up get our money and then dump any support for"

Bought 5 of these with the intend of using them as keyboards.
Biggest waste of money to date. Could have bought any other chip and it probably woulda worked fine.

Looked at the guides you looked at too and changed the usbconfig.h or whatever to whatever he did
added the boot seq as he advised and attempted the hole typeof struct he claimed
Personally i doubt he even got it working didn't post any code think it was more of a "i gave up and said it worked coz i didn't want to look like a tard"

Don't expect any kinda of support from the digispark devs about these major game breaking bug.
They have no intention of fixing this issue that breaks half the point of a keyboard.
Much easier to simply make a half ass keyboard class and slap a done on it

Keyboard.h haven't been modified for the past 5 years according to github.
They have no intention of fixing this first day bug that causes most people who bought this thing to use a keyboard and expected it to work as a keyboard as advertised
to have wasted there money.

as you can read in there source they even label it them self that they only took the barebone and not any support for boot
as you can see in other threads about this major issue in the keyboard class the devs simply wishes the users good luck with fixing there own lazyness

could u imagine that xD imagine you bought a raspberry pi and the raspbian os was broken by default asking for help on how to fix it just got a
ey it's open source gl fixing it for us xD.
Stupid af

Tbh they ain't even making these boards anymore so don't expect anything to be fixed unless it's by a community member.

Im looking at if the raspberry pi w works on boot atm as a replacement for these piece of human shit
« Last Edit: June 01, 2018, 01:43:41 pm by whocares1 »

user0815

  • Newbie
  • *
  • Posts: 2
Re: DigisSpark wont work in Bios Settings :-(
« Reply #3 on: June 04, 2018, 04:11:10 am »
... i can use the teensy 3.2 to work out oft the box with only (!) one Mainboard... AmiBios 2017
it go to bios and i can set automatically my different bios configurations.

other Mainboards dont recognize the device.
I think its in usb_keyboard.h to find a solution.

I dont now to how import a newer usb boot protocol.
if you have some interesting to fix ist,
it was very helpful!


PeterF

  • Hero Member
  • *****
  • Posts: 881
Re: DigisSpark wont work in Bios Settings :-(
« Reply #4 on: June 07, 2018, 12:35:16 am »
From what I've seen on the different forums for different hardware, the low-level keyboard support needed to work with the BIOS is pretty much hit and miss. Then again, one has to wonder how hard can it be since any 'ol dumb keyboard can do it...

whocares1

  • Newbie
  • *
  • Posts: 4
Re: DigisSpark wont work in Bios Settings :-(
« Reply #5 on: June 08, 2018, 06:17:03 pm »
it really shouldn't be that hard its just a matter of getting the right protocol down.
Doing that requires quite a bit of USB knownledge in it self
There is a guy on this forum whom claims to have done it but he didn't feel like sharing the code
and as far as i understand didn't use anything from digispark to do it but instead just barebone coded it