Author Topic: Oak Setup broken?  (Read 6730 times)


  • Newbie
  • *
  • Posts: 6
Oak Setup broken?
« on: March 30, 2018, 07:48:58 am »
I have 5 oaks that I have never been able to set up. I backed the original kickstarter, and have three original oaks that are very stable, so I ordered 5 more but cant get them to work.

First, When I try To get them on my wifi I get this error in my chrome console:


And I can't even get to the part where I select my wifi. I think the issue there is that the setup page is trying to use a secure url (https) for the device ID. If I go to in my browser I see the device ID just fine.

Based on the troubleshooting wiki, I downloaded the local update tool to a machine running windows 10, and then I tried to do the config from a mac on chrome. In that case, I was able to get to the screen where I can select a wifi access point, but when I try to save that I get this error in the chrome console:

Uncaught Error: Expected 0x2: got 0x30
    at newInvalidAsn1Error ((index):970)
    at n.readString ((index):970)
    at Object.publicImport ((index):972)
    at Object.detectAndImport ((index):972)
    at e.importKey ((index):971)
    at new e ((index):971)
    at i.t ((index):973)
    at o ((index):973)
    at r.IncomingMessage.<anonymous> ((index):973)
    at r.IncomingMessage.n.emit ((index):968)

These 5 oaks are stamped "kickstarter edition", but based on these error messages I dont think the hardware is the issue, I think the setup process is broken.


  • Newbie
  • *
  • Posts: 7
Re: Oak Setup broken?
« Reply #1 on: September 01, 2018, 07:17:41 pm »
using a fixed IP, hacking the config.html to use http instead of https, and a combination of Chrome & IE did the trick (IE seemed to be able to get around the 'Uncaught Error: Expected 0x2: got 0x30' error that shows up in Chrome).  I haven't tried it again, I'm reluctant to break something that seems to be working at this very moment. 

In a desperate try to get the Oks's WiFi and registered at I
1 - Open the SoftAP URL;
2 - Input user/password and click LOGIN;
3 - Connect to ACORN-XXXXX but assigned a fixed IP of mask gateway dns;
4 - Click NEXT and surprise!!!!! It went ahead...
5 - Choose WiFi access point;
6 - Input WiFi password;
7 - Had to claim the OAK manually at;
8 - It is working and uploading fron Arduino 1.6.5 R2

Hope it helps to fix the problem with WiFi setup