Author Topic: Cannot build for DigiSpark board  (Read 3034 times)

brbaker

  • Newbie
  • *
  • Posts: 2
Cannot build for DigiSpark board
« on: February 13, 2016, 02:55:10 pm »
Today when I started using the latest release of the Arduino IDE I could not longer build for the DigiSpark board - the board was missing form the list. I looked and the Board Manager let me select the board and download the configuration again. Strange - but okay so I did it.

Now when I build for this board the compile fails with the following error: "Board digispark-tiny (platform avr, package digistump) is unknown"

Has anyone seen this?

Thanks

Bryon
« Last Edit: February 13, 2016, 02:58:19 pm by brbaker »

kuwala

  • Newbie
  • *
  • Posts: 1
Re: Cannot build for DigiSpark board
« Reply #1 on: February 13, 2016, 05:58:37 pm »
I was having the same issue today. According to a post in https://github.com/arduino/Arduino/issues/4137 it can happen when you install and remove boards from the board manager without restarting. I am on windows so this may not work if you are not on windows.

The solution was to remove this folder:
C:\Users\YOURWINDOWSUSERNAME\AppData\Local\Arduino15\packages\digistump
Then reinstall the boards from Digistump with the board manager.

brbaker

  • Newbie
  • *
  • Posts: 2
Re: Cannot build for DigiSpark board
« Reply #2 on: February 13, 2016, 11:10:31 pm »
Thanks. Yes, something makes the board manager have a fit, and that is the solution. I am using OSX so the solution is to remove the package from the Library folder. Library is a hidden folder in OSX so this is done by:
1. Open Finder
2. Click Go > Go to Folder
3. Type /Users/<username>/Library
4. Click Go
5. Open folder Arduino15
6. Delete the folder packages
7. Optionally delete the compressed files in staging/packages