Author Topic: Upload fails on Mac OSX Arduino IDE (launcher error=13, Permission denied)  (Read 8717 times)

maurizio.bollini

  • Newbie
  • *
  • Posts: 1
I got the following message on the IDE:

Sketch uses 668 bytes (11%) of program storage space. Maximum is 6,012 bytes.
Global variables use 9 bytes of dynamic memory.
java.io.IOException: Cannot run program "/Users/maurizio_bollini/Library/Arduino15/packages/digistump/tools/micronucleus/2.0a4/launcher": error=13, Permission denied
   at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
   at java.lang.Runtime.exec(Runtime.java:620)
   at java.lang.Runtime.exec(Runtime.java:485)
   at processing.app.helpers.ProcessUtils.exec(ProcessUtils.java:11)
   at cc.arduino.packages.Uploader.executeUploadCommand(Uploader.java:115)
   at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:158)
   at processing.app.debug.Compiler.upload(Compiler.java:165)
   at processing.app.Sketch.upload(Sketch.java:1167)
   at processing.app.Sketch.exportApplet(Sketch.java:1141)
   at processing.app.Sketch.exportApplet(Sketch.java:1113)
   at processing.app.Editor$DefaultExportHandler.run(Editor.java:2380)
   at java.lang.Thread.run(Thread.java:745)
Caused by: java.io.IOException: error=13, Permission denied
   at java.lang.UNIXProcess.forkAndExec(Native Method)
   at java.lang.UNIXProcess.<init>(UNIXProcess.java:248)
   at java.lang.ProcessImpl.start(ProcessImpl.java:134)
   at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
   ... 11 more


Any clue to fix this?

Regards,

Maurizio

brollejonsson

  • Newbie
  • *
  • Posts: 1
Just had the same problem, to solve it i had to make two files executable. To do this, first open up the terminal. then run the following commands;

Code: [Select]
chmod +x /Users/maurizio_bollini/Library/Arduino15/packages/digistump/tools/micronucleus/2.0a4/launcher  and
Code: [Select]
chmod +x /Users/maurizio_bollini/Library/Arduino15/packages/digistump/tools/micronucleus/2.0a4/micronucleus

That fixed it for me.

Best regards
Olle Jonsson

digistump

  • Administrator
  • Hero Member
  • *****
  • Posts: 1465
Thanks - it sounds like when it was zipped for distribution the miconucleus executables lost their executable flags - I'll fix this ASAP

avenue33

  • Newbie
  • *
  • Posts: 13
@brollejonsson Thank you for the tip!

BillHeintz

  • Newbie
  • *
  • Posts: 2
FYI:  I recently got the same messages as the OP and was able to "fix" the problem with the commands to Terminal.

The reason I mention it is because this problem still exists.

smartynov

  • Newbie
  • *
  • Posts: 7
Re: Upload fails on Mac OSX Arduino IDE (launcher error=13, Permission denied)
« Reply #5 on: November 28, 2015, 02:16:15 pm »
I confirm the bug is still there. It is nice that google gives this page among first few links .)