Author Topic: Upload problems with Digispark  (Read 441 times)

tenuo

  • Newbie
  • *
  • Posts: 1
Upload problems with Digispark
« on: August 02, 2019, 05:17:57 am »
Hello,
after happily using my Digispark for months, I encountered a problem today when I tried to upload some new code. This is the error message from the Arduino IDE:

Code: [Select]
Running Digispark Uploader...
Plug in device now... (will timeout in 60 seconds)
> Please plug in the device ...
ERROR: Device alraedy plugged in.
> Press CTRL+C to terminate the program.
Please unplug the device until prompted to plug it in.
> Device is found!
connecting: 16% complete
connecting: 22% complete
connecting: 28% complete
connecting: 33% complete
> Available space for user application: 6012 bytes
> Suggested sleep time between sending pages: 8ms
> Whole page count: 94
> Erase function sleep duration: 752ms
parsing: 50% complete
> Erasing the memory ...
erasing: 55% complete
erasing: 60% complete
erasing: 65% complete
>> Eep! Connection to device lost during erase! Not to worry
>> This happens on some computers - reconnecting...

After that, nothing happens. Taking the Digispark out and plugging it in again doesn't help, either.
The same error appears every time.
I definetly DIDN'T plug the digispark in before the IDE told me to do so!!! The error message "Device already plugged in" appeared after i plugged it in.
I am using the Arduino IDE 1.0.4 which i downloaded from DigiStump an a Compputer with Win10. I have the same problem on different computer.

Can anyone help me fixing this problem? Could I program the Digispark with an Arduino nano?