Author Topic: The best drivers for your device are already installed - Windows/10 64bit  (Read 873 times)

raspberrypieman

  • Newbie
  • *
  • Posts: 1
Hi,
  I have a "Pluggable Development Board For ATtiny85" (https://www.ebay.co.uk/itm/253040091295) which has an 8 pin socket for an ATTiny85.
I also downloaded the drivers from here: https://github.com/digistump/DigistumpArduino/raw/master/tools/micronucleus-2.0a4-win.zip,
and installed the 64 bit driver: DPinst64.exe
I then plugged in the device and got: Unknown USB Device (Device Descriptor Request Failed)
In Device Manager, I right-clicked the failed device and chose to "Update Drivers" and pointed it to the folder where I unzipped the Digistump drivers.
Windows then reported: "The best drivers for your device are already installed"

I thought I would just try the Arduino IDE anyway, added the Additional Boards Manager URL: https://raw.githubusercontent.com/digistump/arduino-boards-index/master/package_digistump_index.json in Preferences
Then tried to loaded the "Start" sketch from "Digispark Examples" and tried to upload it to board.
When it prompted me with: Plug in device now... (will timeout in 60 seconds)
I plugged in the device - but it was not recognised and timed out with "> Device search timed out"

I have rebooted, and uninstalled the device several times, and repeated the process.

I don't know what else to do here - any suggestions, please?