Author Topic: SPI Libraries not working?  (Read 889 times)

digi_guy

  • Jr. Member
  • **
  • Posts: 87
SPI Libraries not working?
« on: January 31, 2018, 09:30:27 pm »
I've been trying to get an NRF2.4 network set up, and couldn't get the examples to compiles.

I just tried loading a few of the SPI examples and those failed too. I noticed a comment from 2015 about a "new library" being uploaded, did that ever happen? 

Does anyone know if the libraries are working and/or have been updated?

Thanks

PeterF

  • Hero Member
  • *****
  • Posts: 877
Re: SPI Libraries not working?
« Reply #1 on: February 02, 2018, 11:19:39 pm »
What board support package stuff are you using? The latest version was distributed via the board manager in Arduino IDE, so you can add 'http://digistump.com/package_digistump_index.json' to the Additional Boards Manager URLs entry in the Preferences, and then install the Digistump AVR Boards package in the board manager. Was last updated when Arduino 1.6.7 was current, but all the more important bits 'seem' to work still...