Author Topic: Digispark FW Update / 5 seconds  (Read 776 times)

sparkymike

  • Newbie
  • *
  • Posts: 1
Digispark FW Update / 5 seconds
« on: April 29, 2017, 12:21:40 pm »
Hello, I've tried to cure the 5 seconds delay when booting up by micronucleus-ing a new fw file to my Digispark (actually a downgrade from v1.6 to v1.11, it said "Device has firmware version 1.6" during upgrade), but I got no luck, it still is lagging the 5 seconds during boot up. The fw file I've used was "micronucleus-1.11-entry-jumper-pb0-upgrade.hex" (7361 bytes). Any other versions are not working and give me an error "Program file is xxxx bytes too big for the bootloader!". Of course I've tried the current version(s) from github as well (v2.x), but all without luck. There, I've tried: t85_aggressive.hex and t85_default.hex.

Now I'm back to square one. What can I do in order to get rid of the delay?
Thanks in advance for your valued answer
Kind regards
Michael

PeterF

  • Hero Member
  • *****
  • Posts: 805
Re: Digispark FW Update / 5 seconds
« Reply #1 on: April 30, 2017, 09:58:10 pm »
Hey Michael,

So you want a delay free startup of a Digispark (not a Digispark Pro), and you're happy for the instruction to enter programming mode to be on P0 (i.e. PB0)?

I'll see if I still have the compile stuff set up...

PeterF

  • Hero Member
  • *****
  • Posts: 805
Re: Digispark FW Update / 5 seconds
« Reply #2 on: April 30, 2017, 10:28:58 pm »
Ok, I see where the problem is.  Oh, and that is probably an upgrade... I don't think there is actually a it's 1.6, and 11 comes after 6 ;)

If you use any of the 'current' versions, they will NOT work, as they are the complete image meant to loaded onto the chip using a programmer, not the upgrade image that is needed for it to do it's job. You do want the https://github.com/micronucleus/micronucleus/blob/v1.11/upgrade/releases/micronucleus-1.11-entry-jumper-pb0-upgrade.hex file, and it will upgrade itself after it has had a chance to reboot and run the firmware update. So load it through micronucleus, let it run, and then program something else to it... you shouldn't be able to program it unless you connect P1 to GND then, and the delay should be gone.

theChris1310

  • Newbie
  • *
  • Posts: 1
Re: Digispark FW Update / 5 seconds
« Reply #3 on: November 26, 2017, 02:39:43 pm »
Hey board,

I'm quite new to Arduino and brand new to DigiSpark.
I want to remove the 5sec Bootuptime as well. Tried a lot so far

My environment is a Mac Book Pro with usb-c and OS X 10.12.
It took me a time find a working micronucleus and found this: micronucleus-1.11/commandline/builds/OSX/micronucleus
The DigiSparks are brand new. Uploaded my sketch, and tried to flash the bootloader afterwards.

  • upload my sketch
  • unplug DS
  • flash bootloader
  • waiting for 30sec
  • replugging


nothing happens, no blinking as default, no running of my own sketch.
When I do the flash of the boot loader again, I still see it's installed version 1.6 like the original DS but the Flash, seams to be ok, as the command line tells me 100% and the blink-sketch is not running.

When uploading a sketch I tried quite a bit as well.
  • P0 to GND
  • P1 to GND
  • P5 to GND
  • nothing to GND
with any combination, I get in Atom/PlatfomIO the result of an correctly uploaded Sketch. Uploading to a brand no, not flashed DS with Atom works like a charm.

Bootloaders I tired
  • micronucleus-1.06-jumper-v2-upgrade.hex
  • micronucleus-1.11-entry-jumper-pb0-upgrade.hex
  • upgrade-t85_default.hex
Just to name a few.

Please help me with this:
Is there a default, original Bootloader HEX-File for Download somewhere?
is there a howto I can follow for my setup (OS X 10.12 - USB-C and all the stuff)


Thanks for any Ideas, hopefully....
Chris