Author Topic: Poll of Success/Failure Experiences of v1.0.0  (Read 16528 times)

impressiver

  • Newbie
  • *
  • Posts: 1
Re: Poll of Success/Failure Experiences of v1.0.0
« Reply #45 on: April 04, 2016, 05:32:14 pm »
1x Oak - "Eventual success"

It took a while, but I got there in the end. Using the local updater, this guide and lots of fiddling w/ routers and devices I managed to flash the v1 firmware.

The standard update failed probably a half-dozen times, and so did the local version of the update script. I have multiple WiFi routers, one of which I reconfigured to a channel other than 1. Then I moved stuff around, trying to give the Oak as good a signal as possible while keeping all other WiFi devices as far away as I could. Not sure what did the trick, but eventually it worked.

Oddly, the setup page was still counting down when the Oak rebooted after the successful flash. Upon reboot, it connected to the WiFi as configured and also registered itself with Particle.io. I never saw the "Your Oak updated successfully" screen, But I'd run enough prior attempts to know that the LED triple-blink was new. I scanned my local network and found the Oak at the same IP reported in the oakupsrv logs, checked http://<oak_ip>/system-version and did a fist pump when I saw the response (6 instead of File not found). Then I went to the Particle dashboard and the Oak was listed as a new device.

This is what the LED looks like after successful configuration
I wasn't quite sure how to know the difference between "slow" and "faster" until I saw it.
« Last Edit: April 04, 2016, 06:19:22 pm by impressiver »

atanguay

  • Newbie
  • *
  • Posts: 1
Re: Poll of Success/Failure Experiences of v1.0.0
« Reply #46 on: April 04, 2016, 10:06:53 pm »
Eventual Success

hooked to Raspberry Pi...ran the manual updater Python.

Windows Surface to push the update.

Seems like I got it.

DeslogesB

  • Newbie
  • *
  • Posts: 1
Re: Poll of Success/Failure Experiences of v1.0.0
« Reply #47 on: April 10, 2016, 02:12:40 pm »
Long time passed playing with my OAK's before posting here those days, not easy in fact...

Upgrade to latest firmware was successful at office with 2 units, failed with one that I cannot recover. I still need to try serial...

On the 2 successful units, I was able to upload my sketch. Back to home, nothing worked anymore, upload was always failed but oak was connected to wi-fi and particle. Then, regarding the number of messages related to wifi quality, I switched from my classical home network (Same as office, Ubiquity Access Points) to one old Linksys that I put in 11b mode only with a max TX rate of 2 Mbps. Then suddenly all was back again and working !

Thanks for that to the boot with Pin1 connected to ground to force OAK to enter SoftAP mode.

Now I have to understand why I read from port P6 and P5 does not work the same manner... :-(

In conclusion, try to one old and very crappy WIFI, set it to the lowest possible speed to play with your oak, at least for me this is the working solution I found.

postuma

  • Jr. Member
  • **
  • Posts: 64
Re: Poll of Success/Failure Experiences of v1.0.0
« Reply #48 on: April 10, 2016, 03:57:07 pm »
Eventual success - about 5 retries before it took. One Oak, four to go ...

brohan

  • Jr. Member
  • **
  • Posts: 59
Re: Poll of Success/Failure Experiences of v1.0.0
« Reply #49 on: April 10, 2016, 07:04:10 pm »
Eventual success. Tried 10+ times the "standard" way, then moved to creating my own server / client with 2 computers, worked on the 3rd try. Using Ubuntu 14.01 FWIW.

healthyfatboy

  • Newbie
  • *
  • Posts: 1
Re: Poll of Success/Failure Experiences of v1.0.0
« Reply #50 on: April 23, 2016, 06:11:41 pm »
1 Success
4 Eventual Success
3 Particle Failure

Eventually claimed the 3 manually on Particle. Everything was a huge hassle trying to run on Windows 10 and ended up using an iPad and/or WiFi Hotspot on my phone. Eventually fixed it all on Ubuntu 14.04 and they all seem to be working at this point. Need to try putting code on all of them using Arduino and should be good to go.

malaire

  • Newbie
  • *
  • Posts: 28
Re: Poll of Success/Failure Experiences of v1.0.0
« Reply #51 on: April 27, 2016, 02:10:47 am »
Eventual Success = 1 Oak
Not Tried Yet = 9 Oaks

touliloup

  • Newbie
  • *
  • Posts: 14
Re: Poll of Success/Failure Experiences of v1.0.0
« Reply #52 on: April 27, 2016, 06:13:01 am »
Success = 3 Oaks

pck

  • Newbie
  • *
  • Posts: 7
Re: Poll of Success/Failure Experiences of v1.0.0
« Reply #53 on: May 16, 2019, 02:21:37 am »