The Digispark > Digispark (Original) Support

Can't Upload Program

(1/8) > >>

srz2:
I am new to this kind of thing so i dont know if i'm doing something wrong, but I copy and pasted the sample program and tried to upload it to my digispark through the Audino ready software. I've selected the necessary board and program in the tools menu and when it says to, i plugged in my digispark to upload. After which, the software seems to do nothing and does not progress. Is there another step that I am missing or am I wrong to assume that the program should upload to the device after i plug it in.

Please help,

thanks

deranjer:
Windows or Linux?

If you are in Windows did you run \"InstallDriver.exe\"?

No need to copy and paste it, go to

File->Examples->Digispark->Start

and that is the exact same blink example

Bluebie:
It sounds like the digispark isn\'t connecting. Deranjer is right in thinking it maybe drivers on windows. On linux it could be a permissions error. On Mac OS it should just work. The connector on the digispark is a bit short too, so if the USB ports you\'re trying to use are a bit deep in to the computer\'s case you could try using a little usb extension cable or plug it in to a hub or something like that.

Does the green LED light up when you plug it in? If it does but isn\'t in deep enough to connect data, one thing you can try is using a conductive silver pen or something like that to extend the two data wires in the middle of the USB prong all the way to the edge.

srz2:
I\'m sorry, I should have been more specific...

I\'ve tested digispark on multiple computers

2 different PCs running windows 7
2 different Macs running Mountain Lion (Macbook Pro Retina) and Lion (Macbook Pro early 2012)

Big issue I am having with the macs is that when i try to upload the program on a mac, the ardunio editor freezes my computer (mouse and keyboard). Is there a solution to this? Regardless, it also doesn\'t upload to my digitpark

On the PCs, I\'ve had the same issue with each PC. When I try to upload and plug in my digispark, it can do anything from a couple different things. One, I\'ve actually had it work correctly and everything is fine. Two, the *budum* sounds goes on and off and nothing happens. Three, the *budum* sounds several times, it might recognize it and if it does, it says either the driver is not found/recognized OR it says the USB device in unknown.

What I am aware of:
          - There is a potential problem with the retinas and the USB 3.0
          - Some computers might not have the device going in all the way. I am aware and have taken precautions

Toubleshooting I\'ve done:
           - Uninstall and Redownload the software
           - Uninstall and redownload the driver
           - Tried all the USB ports in each computer with no different results
           - Tried a different digispark (i\'ve got three in my order)
           - Tried with and without anything else connected to it

The only thing I have not done that I will try tomorrow after buying one is using a USB extension cable. HOWEVER I would like different advise than that incase that fails as well unless there can be nothing wrong with the process otherwise (which still doesn\'t answer the macs freezing on the upload)

Any and all help is appreciated!!!

srz2:
ALSO to add on, I make double sure that I\'ve selected the proper digispark board and programming language in the ardunio software editor

Navigation

[0] Message Index

[#] Next page

Go to full version