Author Topic: WiFi (HF-LPB) is going up and down  (Read 3517 times)

akcoder

  • Newbie
  • *
  • Posts: 4
WiFi (HF-LPB) is going up and down
« on: February 12, 2014, 06:30:44 pm »
When I was trying to setup the wireless, I missed the crucial step to not reboot until done with everything. Since then, I've been trying to recover the wifi on my device. I wrote a short program to put the module into AT mode and restore the factory settings (calling factoryRestore and makeFactory).  I tried just factoryRestore, but I still wasn't able to access the device.

At some point in this process, I noticed the HF-LPB AP was going up and down. After I would get notification it had connected, it would go down about 5 seconds later. I ran "sudo iwlist wlan0 scan" during this this, and can confirm that it appears the module is resetting itself.

Code: [Select]
lab@dan-lab:~$ sudo iwlist wlan0 scan
wlan0     Scan completed :
          Cell 01 - Address: AC:CF:23:21:0D:A9
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=66/70  Signal level=-44 dBm 
                    Encryption key:off
                    ESSID:"HF-LPB"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000000000014cedc
                    Extra: Last beacon: 536ms ago
                    <snip>

lab@dan-lab:~$ sudo iwlist wlan0 scan
wlan0     No scan results

If I catch the module when it is up, I can grab the SSID, IP, etc information:
Code: [Select]
SSID: +ok=HF-LPB
IP: +ok=10.10.100.254
Link Status: +ok=Disconnected
MAC: +ok=ACCF23210DA8
Network: +ok=DHCP,0.0.0.0,0.0.0.0,0.0.0.0
Signal Strength: +ok=Disconnected

I would appreciate any help you can give me to get this recovered.

akcoder

  • Newbie
  • *
  • Posts: 4
Re: WiFi (HF-LPB) is going up and down
« Reply #1 on: February 12, 2014, 07:34:04 pm »
Looks like this was a power issue. I connected an external power supply and the wifi comes right up, and more importantly, stays up!

Now the issue I'm having is I can't get the wifi module to accept my STA config. Even though I put in a IP, GW, netmask and DNS, and set it to static mode, it still defaults back to DHCP.

Any thoughts?

digistump

  • Administrator
  • Hero Member
  • *****
  • Posts: 1465
Re: WiFi (HF-LPB) is going up and down
« Reply #2 on: February 12, 2014, 11:21:49 pm »
When it transmits it is pushing many USB ports beyond their abilities to source current - usually it is actually transmitting for such a short period we can get away with it without external power - but some USB ports/hubs are more picky then others or just have other things using that power already. Glad you got it figured out!