Author Topic: DigiFi compilation issues  (Read 2652 times)

avdp

  • Newbie
  • *
  • Posts: 2
DigiFi compilation issues
« on: December 02, 2013, 07:18:47 pm »
I can't see to compile ServerExample (or any other DigiFi sample).   I get this error.  Any ideas?





Arduino: 1.5.5 (Windows 8), Board: "Digistump DigiX"

Using library DigiFi in folder: D:\Documents\Arduino\hardware\digistump\sam\libraries\DigiFi (pre-1.5)



C:\Program Files (x86)\Arduino/hardware/tools/g++_arm_none_eabi/bin/arm-none-eabi-g++ -c -g -Os -w -ffunction-sections -fdata-sections -nostdlib --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf -mcpu=cortex-m3 -DF_CPU=84000000L -DARDUINO=155 -DARDUINO_SAM_DIGIX -DARDUINO_ARCH_SAM -D__SAM3X8E__ -mthumb -DUSB_PID=0x078A -DUSB_VID=0x16D0 -DUSBCON -ID:\Documents\Arduino\hardware\digistump\sam\system/libsam -ID:\Documents\Arduino\hardware\digistump\sam\system/CMSIS/CMSIS/Include/ -ID:\Documents\Arduino\hardware\digistump\sam\system/CMSIS/Device/ATMEL/ -ID:\Documents\Arduino\hardware\digistump\sam\cores\digix -ID:\Documents\Arduino\hardware\digistump\sam\variants\digix -ID:\Documents\Arduino\hardware\digistump\sam\libraries\DigiFi C:\Users\Home\AppData\Local\Temp\build1412616779819121709.tmp\ServerExample.cpp -o C:\Users\Home\AppData\Local\Temp\build1412616779819121709.tmp\ServerExample.cpp.o

C:\Program Files (x86)\Arduino/hardware/tools/g++_arm_none_eabi/bin/arm-none-eabi-g++ -c -g -Os -w -ffunction-sections -fdata-sections -nostdlib --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf -mcpu=cortex-m3 -DF_CPU=84000000L -DARDUINO=155 -DARDUINO_SAM_DIGIX -DARDUINO_ARCH_SAM -D__SAM3X8E__ -mthumb -DUSB_PID=0x078A -DUSB_VID=0x16D0 -DUSBCON -ID:\Documents\Arduino\hardware\digistump\sam\system/libsam -ID:\Documents\Arduino\hardware\digistump\sam\system/CMSIS/CMSIS/Include/ -ID:\Documents\Arduino\hardware\digistump\sam\system/CMSIS/Device/ATMEL/ -ID:\Documents\Arduino\hardware\digistump\sam\cores\digix -ID:\Documents\Arduino\hardware\digistump\sam\variants\digix -ID:\Documents\Arduino\hardware\digistump\sam\libraries\DigiFi -ID:\Documents\Arduino\hardware\digistump\sam\libraries\DigiFi\utility D:\Documents\Arduino\hardware\digistump\sam\libraries\DigiFi\DigiFi.cpp -o C:\Users\Home\AppData\Local\Temp\build1412616779819121709.tmp\DigiFi\DigiFi.cpp.o

D:\Documents\Arduino\hardware\digistump\sam\libraries\DigiFi\DigiFi.cpp: In member function 'void DigiFi::setFlowControl(boolean)':
D:\Documents\Arduino\hardware\digistump\sam\libraries\DigiFi\DigiFi.cpp:30: error: 'class USARTClass' has no member named 'setCTSPin'
D:\Documents\Arduino\hardware\digistump\sam\libraries\DigiFi\DigiFi.cpp:31: error: 'class USARTClass' has no member named 'enableCTS'

digistump

  • Administrator
  • Hero Member
  • *****
  • Posts: 1465
Re: DigiFi compilation issues
« Reply #1 on: December 02, 2013, 07:39:52 pm »
Opps - made a mistake in the last release - download the updated file (same name) here: http://sourceforge.net/projects/digistump/files/DigiXAddons-v05.zip/download and it should work! Sorry about that!

avdp

  • Newbie
  • *
  • Posts: 2
Re: DigiFi compilation issues
« Reply #2 on: December 02, 2013, 07:44:19 pm »
Yep,  compiles fine now!

Thanks for the super fast response.