Author Topic: nRF24L01+ / RF24 not working?  (Read 49647 times)

torchris

  • Newbie
  • *
  • Posts: 17
Re: nRF24L01+ / RF24 not working?
« Reply #30 on: October 16, 2014, 06:19:33 pm »
Good luck! It is a solid board, but some there are a few oddities!

Fadi

  • Newbie
  • *
  • Posts: 4
Re: nRF24L01+ / RF24 not working?
« Reply #31 on: October 18, 2014, 09:18:56 pm »
I would like to take a quick minute to grab the attention of Digistump about this issue.
RadioHead library works.
But I would like to use Maniacbug's library, which is supported as per the Wiki page.

I downloaded the latest addon (v092) and it is a mess. ( at least I think so)
there are two directories now under Digistump:
avr
sam

under sam:
Libraries
     |
     |_ RF24

RF24

(the RF24 under Libraries is original Maniacbug's library, not modified) causes multiple errors with printf and the like.)
(the sibling RF24 next to Libraries has the modified code but also causes errors about SPI defined constants and _BV macro)
I got all errors sorted out but I have no serial output now and no way to verify it works before moving to the next step and start a 2-party communication.
Basically, I copied/pasted and gum-glued bits and pieces to see if I can make it work.

Digistump, can you please provide us with a working library (through the addons or externally)?

Thank you.


digistump

  • Administrator
  • Hero Member
  • *****
  • Posts: 1465
Re: nRF24L01+ / RF24 not working?
« Reply #32 on: November 08, 2014, 06:19:18 pm »
Fixed versions attached - will be updated in the next release

pckk

  • Newbie
  • *
  • Posts: 8
Re: nRF24L01+ / RF24 not working?
« Reply #33 on: May 16, 2019, 10:32:12 pm »
thanks fro support me.  :-*
สมัครufabet