Author Topic: Digispark and Radiohead on arduino 1.04  (Read 3288 times)

archigraphe

  • Newbie
  • *
  • Posts: 2
Digispark and Radiohead on arduino 1.04
« on: October 24, 2015, 03:22:39 am »
Hello,

I'm using Digispark as transmitter in a datalogging system.
I use Radiohead RH_ASK 1.49 driver on arduino 1.04 .

It compile well with 8Mhz tiny and digispark
but no signal at the end....

the code I'm using:   

 
// ask_transmitter.pde
// -*- mode: C++ -*-
// Simple example of how to use RadioHead to transmit messages
// with a simple ASK transmitter in a very simple way.
// Implements a simplex (one-way) transmitter with an TX-C1 module

#include <RH_ASK.h>
//#include <SPI.h> // Not actually used but needed to compile





RH_ASK driver(2000,4,3);; // 200bps, TX on D3 (pin 2), RX on D4 (pin 3)

void setup()
{
    /*Serial.begin(9600);     // Debugging only
    if (!driver.init())
         Serial.println("init failed");*/
          pinMode(1, OUTPUT); //LED on Model B
          digitalWrite(1, HIGH);
          delay(1000);
          digitalWrite(1, LOW);
          delay(1000);
          digitalWrite(1, HIGH);
          delay(1000);
          digitalWrite(1, LOW);
          delay(1000);
          digitalWrite(1, HIGH);
          delay(1000);
          digitalWrite(1, LOW);
          delay(1000);
          digitalWrite(1, HIGH);
          delay(1000);
          digitalWrite(1, LOW);
          delay(1000); 
          //pinMode(3, OUTPUT); // transmission on Pin 3 (D2)
}

void loop()
{
    const char *msg = "20";
    digitalWrite(1, HIGH);
    driver.send((uint8_t *)msg, strlen(msg));
    driver.waitPacketSent();   
     delay(200);   
    digitalWrite(1, LOW);   
     delay(200);
}
 


archigraphe

  • Newbie
  • *
  • Posts: 2
Re: Digispark and Radiohead on arduino 1.04
« Reply #1 on: October 26, 2015, 02:55:19 pm »
So,

I pass to IDE 1.6.5 and all is working well,

the digispark are good to go....

with the specs of the attiny board,

drivers (2000,4,3)

no SPI def...

and with digispark (16.5Mhz)....

arturoreynoso86

  • Newbie
  • *
  • Posts: 1
Re: Digispark and Radiohead on arduino 1.04
« Reply #2 on: May 13, 2018, 01:01:07 am »
Hello!

How did you managed to make it work?

Regards!