Recent Posts

Pages: [1] 2 3 ... 10
1
Digispark (Original) Support / Usage of DigiSpark pins PB1, PB3 and PB4?
« Last post by DuinoSoar on July 18, 2019, 02:14:08 pm »
Hello, again.

For some of my potential DigiSpark projects, I am wondering about using pins PB1, PB3 and PB4 for functions where the on-board LED (for PB1), or the USB port (for PB3 and PB4), are not required for the application.

With the various resistors, Zeners, and the LED hanging off of these pins (and, don't forget about that 1.5 K pull-up on PB3 near the USB connector!), what special precautions (if any) need to be considered when using these pins in any of their available functions?

For example (and without limiting the discussion to these), in reference to the "official DigiSpark schematic" at https://s3.amazonaws.com/digistump-resources/files/97a1bb28_DigisparkSchematic.pdf [PDF]:
  • How would the USB components (R1, R2, R3, D1 and D2) affect using PB3 or PB4 in the various digital or analogue modes?
  • Could PB3 even be used as an analogue input, given the R3 pull-up (1.5K)?
  • What about trying to use PB3 as digital input WITHOUT pull-up?  Is that even possible?
  • How would the LED and the R5 "pull-down" affect the use of PB1?
Is there a web page or document somewhere that describes these issues?

Oh, and while I am at it, is diode D3 (connected between the USB +5V pin and the board's +5V Vcc "rail") being used in some kind of special mode, or is that an error in the schematic (i.e. it looks backward)?  And if it is an error, why has this "official schematic" never been corrected?

Thanks and best regards,
   DuinoSoar.
3
Hello.

While compiling ("Verifying") the DigiCDC "Echo" example, I got the error (replaced the base part of the file path with "..."):

Quote
Error while detecting libraries included by ...\AppData\Local\Arduino15\packages\digistump\hardware\avr\1.6.7\libraries\DigisparkCDC\usbdrvasm.S

Is there something I need to do to fix the above error?

In spite of this error, the compilation seemed to complete, anyway, and reported the amount of space used/remaining, etc.  So I tried "uploading", the program to the DigiSpark, and when it started running, Windows 10 reported a USB device error:

Quote
USB device not recognized The last USB device you connected to this computer malfunctioned, and Windows does not recognize it.

I tried unplugging and re-plugging DigiSpark from/to USB and, after the 5-second bootloader timeout, got the same error.  I already installed the DigiStump drivers in Windows 10.  Is there another Windows driver that I must install for DigiCDC?

Also, perhaps I missed it, but I did not see anywhere, how a terminal emulator (or, for that matter, Arduino IDE Serial Monitor) should be set up to communicate serially with the DigiSpark over USB/CDC?  What baud rate and bit protocol should be used on the PC side?  (I understand that the DigiSpark CDC library does not need a baud rate, but I am asking about the PC side setup.)

Is there a more detailed reference or user documentation somewhere for DigiCDC, including a list of all API calls, etc., and how to set up the serial communication on "the other side" (i.e. the device or terminal with which DigiCDC is communicating)?

I would really like to get this working, as i have a project in mind to use it.

[Just edited the above.  I just today noticed the "Modify" button near the top of my posts, so I fixed this one and deleted the other two "replies" that I posted yesterday.]

Thanks and best regards,
   DuinoSoar.
4
Digispark (Original) Support / Re: Digispark attiny85 board can´t LOW PB pins
« Last post by granzeier on July 16, 2019, 12:12:29 pm »
Did you configure the pin as an output with PinMode (https://www.arduino.cc/reference/en/language/functions/digital-io/digitalwrite/)?
If the pin is configured as an input, when you try to write a low, it will disable the internal pull-up resistor, and you will see a float.
5
Digispark (Original) Support / Digispark attiny85 board can´t LOW PB pins
« Last post by smascare on July 16, 2019, 04:28:57 am »
Hello All Community!

I´m powering digispark attiny85 with 9V in the Vin and Gnd pins.

When programming any pin to set to LOW in the OUTPUT, i verify high voltage in that pin (about + 3V).

When i use digitalWrite(2, LOW) not obtain a Low voltage on pin 2.

What is wrong?
6
Official Announcements / Re: ChibiOS on Digispark Pro
« Last post by mena on July 15, 2019, 09:57:46 pm »
Thank you very much Very useful >>>>ดาวน์โหลด slotxo
7
Oak Support / Can't configure Wi-Fi after "restoring your oak to factory setting"
« Last post by jirapon on July 15, 2019, 02:36:13 am »
I don't know if the following is the cause of my issue. I cannot store my wifi settings on my oak. I is perpetually blinking 3 burst led then pause.

So I finally got myself a uart and got the latest firmware on my oak successful. I've been following the instructions from: https://github.com/digistump/OakRestore. However I have a problem. The following text is written on that page:

"This will not restore an Oak that has had its Particle Config overwritten at 0x100000 and 0x201000 - a device where that has occured can be partially restored by this method but then will need its device id set via serial, and you'll need to have recorded it previously. Then connect at 115200 baud and send set\n40\n{"device-id":"123456789012345678901234"}\n where 123456789012345678901234 is replaced by your device-id. You can also send a raw POST to 192.168.0.1/set with the same JSON while connected to the AP of the Oak"

I do know my device-id however the rest of that text didn't make much sense to me. How do I: "Then connect at 115200 baud and send set\n40\n{"device-id":"my device id"}\n"

And then: "You can also send a raw POST to 192.168.0.1/set with the same JSON while connected to the AP of the Oak""

Any assistance would be greatly appreciated.
เว็บแทงบอล
แทงบอล
แทงบอลออนไลน์

8
Oak Support / Re: Oak Setup broken?
« Last post by yoyo4456 on July 14, 2019, 08:26:51 pm »

Online slots, play on mobile
Easy to play, earn real money
Win Jackpot all the time
.
.
.
apply at : slotxo
9
Digispark (Original) Support / Digispark Not Appearing in Win10-Dev
« Last post by dxmaster on July 14, 2019, 06:57:25 am »
So, I'm using the insider build of windows 10 on one of my laptops and when I plug in my digispark windows isnt even acknowledging the fact that something was plugged in. I tried multiple USB ports both direct off the computer and on hubs and none of them are showing the device appear even for a split second in the device manager. Also, the driver installation states that my version of windows is not supported. It seems work work just fine on my Surface Pro.

Any suggestions on what might be causing this? Is there something where this was blocked entirely in the newest windows insider builds?
10
Digispark (Original) Support / Re: Abort Mission, -1 error
« Last post by NyanWinux on July 13, 2019, 10:56:27 am »
I Got exactly the same error. Sometimes i'ts Error -32 instead of -1.
I tried all sort of USB ports, 2.0, 3.1, hubs or not. It never worked.
I use Ubuntu 19.04, Arduino IDE 1.8.9.
Pages: [1] 2 3 ... 10