Digistump Forums

The Digispark => Digispark (Original) Support => Topic started by: frednet on May 11, 2020, 04:58:43 am

Title: Ubuntu 20.04 64 bit library problem (SOLVED)
Post by: frednet on May 11, 2020, 04:58:43 am
I'm trying to upload some code to a digispark board but it won't work due to a library issue. It appears loads of people have have a similar issue but I've tried the suggestions and they haven't worked. The error I get is  error while loading shared libraries: libusb-0.1.so.4: cannot open shared object file: No such file or directory
The first thing I tried was replacing the micronucleus file in the 2.0a4 directory as someone mentioned in this
https://digistump.com/board/index.php/topic,1693.0.html (https://digistump.com/board/index.php/topic,1693.0.html)
but I get a permission denied error as a result. Then I changed the permissions to the same as the original (including making it executable) and I'm back with the same error.
I then tried installing install libusb-0.1-4:i386
but it made no difference.
Every post I looked at was quite old, finally I found a post suggesting this sudo apt-get install libusb-dev
which then fixed that error but now hit me with a new one!
Now I get the request to Plug in device now... but when I do I get the following micronucleus: library/micronucleus_lib.c:66: micronucleus_connect: Assertion 'res >=4' failed.
Does anyone have any idea how to get it to work correctly? Is the linux driver unmaintained or something?
Title: Re: Ubuntu 20.04 64 bit library problem
Post by: frednet on May 11, 2020, 05:07:23 am
Finally fixed it, I needed to add a udev rule as per this post.https://digistump.com/board/index.php/topic,106.msg1565.html#msg1565 (https://digistump.com/board/index.php/topic,106.msg1565.html#msg1565)