Digistump Forums

The Digispark => Digispark (Original) Support => Topic started by: TheSecondQuincy on December 30, 2019, 06:34:08 pm

Title: Digipark Attiny85 just won't work : /
Post by: TheSecondQuincy on December 30, 2019, 06:34:08 pm
So I've literally never programmed a thing in my life, so ahead of time I apologize if these kinds of questions just sound super stupid / basic or if there's a simple solution I just can't figure out from lack of experience.

To summarize, I bought this board to try and follow a DIY volume knob tutorial I want for my PC build ( https://www.instructables.com/id/Digispark-Volume-Control/ ). I really don't think it's difficult for me to manage, but I've been stuck at basically step 0.5 on this operation for the past few hours. I've probably ready and watched six different video and forum tutorials (even read through some of here trying to google troubleshoot, none were specifically applicable) but nothing I've tried has gotten my computer to recognize it period. I can plug it in and the little LED light turns on, but the little "ding" that tells you Windows noticed a device was plugged into a port doesn't happen, and nothing pops up in the device manager, even briefly. I've installed the drivers, set Arduino up with the proper board manager and programmer (at least for the one recommended - I've seen a few videos showing a specific Digispark programmer but I can't find a link for that anywhere or any indication of how you get it otherwise. I've figured out the actual program itself, so if I can get this thing to connect I'm confident I can go from there.

TL;DR my main questions are:

Here's a list of the tutorials / troubleshoot guides I've tried:
https://www.instructables.com/id/How-to-Setup-DigiSprak-Attiny85-Board/
https://digistump.com/wiki/digispark/tutorials/connecting
https://www.youtube.com/watch?v=U3wj9dQt50Q&ab_channel=MissionCritical
https://www.youtube.com/watch?v=MmDBvgrYGZs
http://digistump.com/board/index.php/topic,2827.0.html
https://digistump.com/board/index.php?topic=2825.0

It's possible I just happened to buy a defunct board, but if there's anything else I can try before I end up buying another one, I'm open to suggestions.
Title: Re: Digipark Attiny85 just won't work : /
Post by: granzeier on December 31, 2019, 04:53:57 am
One thing that has helped me is to program the Digispark through a USB hub (preferably powered, but unpowered has worked too.) Give that a try and let us know what happens.
Title: Re: Digipark Attiny85 just won't work : /
Post by: TheSecondQuincy on December 31, 2019, 11:00:59 am
Thanks - I did see that suggestion a few places but didn't have one on hand to test it out. I'll get one ordered and update once it comes in!
Title: Re: Digipark Attiny85 just won't work : /
Post by: TheSecondQuincy on January 03, 2020, 05:14:24 pm
So USB hub came in today - plugged in the board, and after some finagling, that seemed to do the trick! Thanks for the suggestion, I knew it had to be something really minor / silly I wasn't coming up with.
Title: Re: Digipark Attiny85 just won't work : /
Post by: granzeier on January 04, 2020, 05:55:49 am
Great! I'm glad that you got it working. Thanks for letting us know.
You are right about solutions often being minor/simple/silly, but this is one that, while simple, is not easy to figure out on your own. It really helped me when I saw this fix from Digistump.